560SEL EHA replacement

Today’s job was EHA replacement (Electro-Hydraulic Actuator) on my 1987 560SEL.   The EHA is part of the KE Jetronic fuel injection system and makes minute adjustments to the air/fuel mixture.   One of the sources for these adjustment is the oxygen sensor, if present.   The EHA can leak either because the o-rings between the EHA and the fuel distributor have gone hard, or because of internal leaks in the EHA itself.   In the case of my car, it looked like the EHA was leaking, not the o-rings.

The EHA is still available from Bosch, but it is not cheap.   Still, I can only imagine it will get more expensive in the future.   It is easy to tell if your car has a replacement unit as the screws holting it on will be torx.    The original ones are flat head.  If it is not pretty clear the EHA is leaking, it can be worth trying to change the o-rings first.

EHA replacement

The EHA is accessible once the air cleaner assembly is removed.   It attaches to the side of the fuel distributor, near the fuel pressure regulator.    Its only a 10 minute job to change it out.  The most important thing is to make sure the o-rings are seated properly.   I like to put some paper towel underneath the EHA during this process.   Not only will it catch any fuel that leaks out, but it will also catch the o-rings if you drop them.

Obviously, as I was working with fuel I had disconnected the battery.   Since I was doing the battery tray at the same time, I had remove it completely.

EHA replacementEHA replacementThe EHA makes minor adjustments, but it is possible to adjust for baseline settings.   I already covered the adjustment of the EHA in a previous article.   It is worth watching the two videos linked in that article.   I hooked up my gauge set to check the pressures.  My initial readings were 5.9/6.35.   The ideal pressure differential between control pressure and working pressure is 0.4.    I adjusted the EHA 1/4 turn, which changed my pressures to a tad above 5.8 and 6.35.    This mean the differential was very close to 0.4, just a tiny bit over.   This was exactly where I needed it to be.   These pressures are tested with the EHA unplugged as I was trying to set baseline pressure.

After re-checking the pressure then removing the gauge set I carefully checked for any leaks.   After the EHA replacement I took the car for a test drive it felt no problems.   At this point it is normally worth checking the idle mixture.   My injectors are about to be replaced, so that would be premature.

EHA replacement complete

 

November 2020 Night drive to Bilpin

The monthly late night drives are really starting to gain momentum.   This month was a bit different.  It started out as a Night drive to Bilpin.   As well as a drive, we had late night dessert and coffee.   Summer in Sydney is a great time for night drives.  The weather is pleasant and its a great time for convertibles or sunroofs to be open.

The drive started from the McDonalds car park in Windsor.   From there, the drive took us up Bells Line of Road to the Apple Pie Cottage in Bilpin.   The Apple Pie Cottage is run by a club Member, Sam, who opened just for us.    It was a pretty good event all around.  Hot apple pie and ice cream after a nice drive.   Bells line of Road is much nicer at night when there is less traffic.

The meeting time was 9:30PM.  Quite late, but it allows for people who work late or have kids to do what they need to do and home and then get to the meeting point.   We had 24 registrations for the drive, and a great turn out on the night.

Night Drive to Bilpin

One the drive we had a nice mix of old a new.   I took my 250SE Cabriolet.  A perfect night for open topped motoring.   A few others agreed as we had three R107s,an R230 and an SLK.   Also along was a W108 280S, a pair of 450SLCs, a 280CE, a W140, two W126s, an AMG GT and an AMG CLA45S.    The amount of power AMG get out of that 2.0 liter 4 cylinder engine in the CLA is staggering.   Not sure I would still possess a licence if I owned this car.

The two 126s are both lovely cars.  The 420SEL has just come out of major dash out work replacing the evaporator, and it was good to see it on the road again.    The 280SE belonged to a new member and it was a real time warp car in a great colour.   You can even see the condition of the paint under the wheel arches in the photo below.

280SEThe W108 280S is a really interesting car.  Its a subtle light green colour with a red MB-TEX interior and a manual transmission.  Most of the W108 cars that came to Australia were automatics in white, so this car is quite unusual.      I like it.

The Apple pie cottage, our destination for the night drive to Bilpin was also our destination earlier this year for a regular club drive.   We all enjoyed the dessert and coffee and left quite late for the drive home.

W126 battery tray

The W126 battery tray serves a dual purpose.   The first and most obvious is to keep the battery in place.  The other is to protect the body work.  Over time car batteries can leak acid and the removable tray catches all that.    It is worth checking the condition of the battery tray each time the battery is replaced.   If the battery tray becomes too corroded then it can no longer protect the body work.

It is also worth checking the W126 battery tray for another reason.   It is easy for leaves to accumulate under the battery tray.   This can cause rust, especially on cars that park outside.   The leaves never really dry out and rust starts to form.    My 560SEL is in excellent condition and has been garaged all its life.   It still had a fairly nasty battery tray with a lot of leaves stuck underneath it.

W126 battery tray

The W126 battery tray was worse than the one I fixed on my 450SLC.   As the bolts were a bit rusty I soaked then in penetrating oil.  The tray is held on with four bolts and a nut.   Two that attach to the firewall, a big one on the bottom left that is obscured by the wiring loom and a smaller one at the top left that doens’t actually hold the tray on, it attaches a bracket for a power distribution block.    The nut would be visible on the bottom right but is obscured by leaves.

Normally there is a bracket that holds the battery to the tray.   This was missing on my car so I have ordered a new one.   There are two nuts that hold this bracket to the tray.    These can be seen in the next photo after I removed the leaves and applied the penetrating oil.

W126 battery tray

After the use of the penetrating fluid the bolts and nut removed fairly easily.   I was then confronted with a massive volume of leaves and debris.   After vacuuming them away, I also found an EHA o-ring and a washer, I guess they had been dropped there over the years.    I find a vacuum cleaner is ideal to remove this debris – even a household unit is fine – I am using my grandmothers old 80’s electrolux in the garage and its fine.   This vacuum cleaner pre-dates the car.

W126 battery tray

I was pretty lucky.  Despite all that debris, there was no rust apparent on the body work.   This is likely because the car has been garaged all its life.   I don’t think a car parked outside would fare very well as the leaves would never dry out properly.   The only area I had to treat was the captive bolt that helps attach the battery tray.   There was a very slight amount of rust at the base of this bolt that I treated and painted.

Fixed rust

overall the area looked very good once the debris was removed.   The big bracket that can be seen in the photo holds the sway bar bushing on.

cleaned debris

Once the area had been cleaned I started work on the tray itself.   As with the 450SLC, I used a wire brush attachment for my drill to remove as much of the rust as possible.   In one area of the tray it was quite corroded.    The photo below shows the tray with the rust removed.  Unfortunately I forgot to take a photo before starting to spray the primer so there is a little primer there.  The side shown was worse, but there was also rust on the underside, in particular where the attachment tongue joins the tray.

W126 battery tray

I used a separate primer on the W126 battery tray before the paint.   Probably if I wanted an even better finish I would have the tray powder coated.   This isn’t something I can do myself.

W126 battery tray

After priming, I applied two top coats.  I think both of my coats were too heavy as the paint ended up a bit soft.    I made this same mistake when I did the 450SLC tray as well.   Something to work on next time I restore a battery tray.   I’ve not inspected the trays on my 300SE or 560SEC, and they’ll probably need doing too.   The photo below shows the freshly painted tray and the corroded areas are quite apparent.

W126 battery trayOnce I finished, installed the battery tray and the new battery I purchased a couple of months ago.   The old one was working, but it failed the battery test.  I didn’t want to be left stranded with a bad battery.

300SE low oil pressure gauge

Today I took my 300SE on a Mercedes Club Pop up drive.   The Pop up drives are short notice mid-week drives.  I normally take the other cars to club events, but the 300SE had not been on a decent run for a while and the weather was terrible.   The drive was down through the Royal National park to Mt Kembla, Mt Kiera and then back.

The other cars on the drive were rather varied.   There was a Ferrari 458 Spider, an Audi SUV, a race prepped Toyota Yaris and a couple of other Mercedes including a C63, C250 and E400 Cabriolet.    It was quite amusing to be in a convoy in my 300SE following a C63 and the Ferrari.   I think the power difference was probably about 500hp.

Ferrari

It is also my first drive in the 300SE now on historic registration.   I now no longer have any cars on full registration, and will rotate the 60 days I have available on each car.   The roads were quite good even in the wet.   The view from Mt Kiera was also quite nice over North Wollongong.   The W126 does quite well for a softly sprung limo.

North Wollongong

After leaving the meeting point I observed some strange behavior on my 300SE’s oil pressure gauge.    The normal behavior is the car idles above 1 bar when hot and pegs when accelerating.     All of a sudden, the reading was negligible at idle and rose very slowly on acceleration.    At this point I was not sure if I really had low oil pressure.

My first step was to stop and check the oil level in the car.   The level was on the low side, just above the low mark.   I added some extra oil and it made a very slight difference.   Even with the much lower gauge reading, the pressure was just inside the spec in the owners manual.   Based on that, I kept going on the drive.  The car was running really well and I was starting to think it might be a gauge problem rather than an engine problem.     Just in case I was easy on the engine and kept the revs below 3500.

When I got back I did an oil and filter change.   The car was due for one and this would eliminate contaminated oil. It’s been a year and about 5,000km.  The dipstick looked fine, but there was an outside chance the oil was contaminated with petrol or coolant.   As a tip, trying to do an oil change quickly just results in a lot of spilt oil.

Oil pressure reading

After the oil change there was very little change to the oil pressure gauge reading.   Next was to run the engine without the oil cap.   I wanted to see that oil was getting to the top end of the engine.   I could see a steady stream over the cam lobe.   This made me think that I have good oil pressure.     If this is correct, then the issues is either in the sender unit, or the gauge.    On some further research, the sender units fail with the same symptoms I have.

The other possibility is that the oil pressure relief valve is stuck open or partially open and I really have low oil pressure.     The evidence seems to point to the sender unit.     I’ll be ordering one and replacing it as my next step.   The best troubleshooting step would have been to attach a mechanical oil pressure gauge but I don’t have one.

There is never a dull moment with old cars.

Youngtimer Sacco Day 2020

The Mercedes Benz club NSW ran an event today to commemorate the cars of Bruno Sacco.   Sacco was head of design at Mercedes-Benz from 1975-1999.    The event was called Youngtimer Sacco day and I understand the intention is to make it an annual event.   Given the success of today’s event, I can easily see why.

The event started out at Tynan’s Mercedes-Benz dealership in Southern Sydney.   They were also the sponsors of the event.   Tynan’s is a large dealership, but their forecourt was soon overwhelmed by Saccomobiles as event attendees started to roll in.   The event was capped at just over 100 attendees due to COVID restrictions at the venues.   Had it been a normal year, numbers would have probably been even higher.

I took my 560SEL to the event, as the W126 is a Sacco creation.   I read an interview with him a few years ago and I seem to recall the 126 SEC and W201 as being to designs he is particularly proud of.   Others who attended the Youngtimer Sacco day clearly had a similar idea as the W126 was by far the most popular car there, mostly 420SELs.   The 420SEL is very popular in the club, so much so it’s almost a membership requirement!

Youngtimer Sacco day

There were of course other models represented at the Youngtimer Sacco Day.   There were a few nice W201s, W124s etc, although the numbers skewed to the 80s models and there were only a couple of the 90s and 2000s in attendance.   For the W124s there was at least three rare A124 cabriolets as well as a real AMG Coupe.

The first leg of the day took us through the Royal National Park on the Grand Pacific Drive.   This is a nice (but busy) drive through some good roads in the national park and over the sea cliff bridge.

The morning tea break was at HARS Aviation Museum.   This is one of those places I have been meaning to attend for years and never got the chance.   They have a really interesting collection of aircraft significant to Australian Aviation.   Its definitely worth a visit.    Not only was the museum really interesting but the line up was extremely impressive.    I took a couple of my young children to the event as they were interested in seeing the Aeroplanes.

Youngtimer Sacco dayIt would have been logistically difficult, but it would have been quite cool to get them lined up my model given the number.   In any case, given it was Youngtimer Sacco Day, the Saccomobiles were all in the first row and then the other Mercedes-Benzes behind.

Once we finished up at HARS, there was a great route selected to take us to Moss Vale Golf Club for Lunch.    There were some great twisty parts of this road.   Surprisingly there was even a little floodway with about 1″ of water flooding through.   There were a couple of low slung AMG cars at the event that probably had to detour, although it was no problem for the W126.

The lunch at Moss Vale was quite nice, done in multiple sittings to comply with COVID restrictions.

Youngtimer Sacco DayThe Club, in conjunction with Tynan’s had some nice door prizes.  I was lucky enough to win some detailing products.    The day was a big success and a credit to the organizers.   I hope it does run again next year.   Maybe they should also consider an Oldtimer Bracq day?   This could commemorate the cars of Paul Bracq including the W108/W109, R113, W111C, W100 and W114/W115.

250SE extended test drive

After all the recent work done on my 250SE, I wanted to take it for an extended test drive.   Its had motor and transmission mounts, front crank seal, re-sealed power steering pump, injectors, distributor cap and rotor, points, condenser, coil, plugs, alternator, voltage regulator and more done.     The spark had been quite weak and the engine was carboned up.

The Mercedes-Benz club have started running mid-week pop-up drives.  I’m not normally able to attend mid-week events but I have a bit of time at the moment.   This weeks drive was down to Berry via the Royal national park then back via Macquarie Pass.

extended test drive

In order to keep up with the other cars on the twisting roads and steep inclines required a lot of use of the higher rev ranges of the M129.    The car certainly seems to be running better after this extended test drive.    We had four cars on the drive, a R107 380SL 5.0, a BMW 545i and a C250.

extended test drive

While the car is running much better now, I did have a couple of other issues to contend with.

The first was strange behavior from the radio.   It stopped responding to inputs of the buttons, and event more strangely continued to play even after I had shut the car off and removed the key.   This is quite odd as the radio has two power inputs.   A constant 12v and a switched 12v.   It is not supposed to work without the switched 12v.

Disconnecting the battery obviously caused the radio to power down.   Even after a 20 minute coffee break which I thought might reset things, it was still operating strangely.    It powered back up but was still not responding to button inputs.  I could not turn it on, and it remained in standby even after I turned off the car.    As you can see from the photo, the key is out but the radio remained on.

Radio gremlinsI also had a problem where my A/C was not blowing especially cold and would sometimes stop cooling at all.   If I turned it off for a while and turned it back on again, I would get some cold, but it wasn’t that cold.    I don’t think it is low freon because it would be cold for a little while and the compressor clutch remained engaged even when it wasn’t cold.

At one point I was thinking maybe it was an ignition switch problem?   However, I was soon able to eliminate that.   I removed the radio from the car and tested the two 12v inputs with a multi-meter.   The switched voltage was behaving exactly as it should.  Even more oddly, once I plugged the radio back in in, it behaved normally.   I’m not really why it would reset when removed when it didn’t from a disconnected battery.

working radio

With the ignition switch ruled out, and the radio working again, it was back to the drawing board for the A/C.   I will need to have the car checked, a set of gauges should be able to check if the freon level is sufficient.  It may also show up something like a bad expansion valve.

Still, the MBCNSW Pop up drive proved to be a good day out and a great extended test drive for the 250SE.

250SE Alternator replacement

On the way back from the September night drive my 250SE stopped charging properly.   I was able to make it back home about an hour on the battery.   Even using the headlights the 250SE does not use a lot of power.   As it happened, a friend of mine had a rebuilt alternator that was correct for my car.   He drives a 280SE 3.5 W108 which uses a 55A Bosch alternator.   The earlier cars (to 1969) used a 35A alternator which is what he had.   This is the correct 250SE Alternator.

Initially I assumed I would replace the alternator myself.   It didn’t take long to change my mind.   The alternator is inaccessible from the top due to the A/C compressor.   It is hard to get from the bottom due to the air filter box too.   I decided that this was a job for the professionals and I am glad I did as it turned out to be a 7 hour job.  The 250SE alternator is just visible underneath the compressor.

250SE Alternator

Additionally, with the alternator out, it was apparent that a nearby coolant pipe had seen better days.   It was a good opportunity to have it replaced.  Its amazing it wasn’t leaking like crazy given its state.  There was also some wiring replaced at the same time.

Coolant pipe

I kept the old alternator.  Parts are getting hard to find for these cars now and it is likely rebuildable.

250SE Alternator

As well as replacing the Alternator, I also replaced the regulator.  I had hoped to buy one of the Bosch solid state regulators, but I think they are no longer available.  I could only find one vendor selling them and they wanted almost $500USD for it.   In the end I got a Beru unit.   The voltage regulator in the car was a Bosch points type, but was not the original one.   It looks like it was originally for another car as a small separate adaptor was needed to plug it into the cars wiring harness.

250SE Voltage regulator

The old one was still working, but I am getting better voltage out of the new one.   Curiously, one of the pins was not connected on the old regulator.   I’ve had the car for more than 8 years and it was working, so not sure the impact.   I’ve been able to plug the new regulator into the main plug.   As with the 250SE alternator, I will be keeping the old regulator and that extra harness as a spare.

The rebuilt alternator and new regulator make good voltage and 35A seems sufficient to power the car – even with the A/C which is not original to the car.   There are no ECUs or other power hungry accessories on this car.   The fuel injection is mechanical, so the only power draw required to run the car is the fuel pump and ignition system.   The other main accessories are the car’s lights, the radio and the A/C.

M129 rough running

Over the last couple of months I’ve had issues with the M129 rough running in my 250SE.   The car was hesitating, idling poorly and just not running very well.   I’ve done a few things over the last few months to improve this situation.

One of the first things I did was change the injectors.   The stutter when accelerating and hard starting when hot felt like a symptom of poor injectors.   I also didn’t want the situation of a leaky injector washing down my cylinder walls.   While not as cheap as the K Jet injectors, the MFI injectors are still available from Bosch and are not exorbitant.   The same cannot be said for the special ones used on the 6.3!  I didn’t do that job myself as it requires a special tool I do not have.     I had this job done at the same time as having the valves adjusted.

The next is a solenoid on the transmission that was impacting idle in gear.   The idle was too low even when adjusting with the idle air screw.    I’m not exactly sure what was wrong here, but it did fix my low idle problem.

The car also had a weak spark, so I had the coil and points changed.    When that was done, it was pretty apparent that the cap and rotor needed changing too, which is the part of the job I did myself.   This should have been so routine I would hardly need to mention it here, but there were a few things that I discovered along the way.

On the 80s cars, the distributor caps are marked with the cylinder numbers which makes installing them dead easy.   The older caps are not so marked.   This isn’t a problem if you’re just replacing the cap, as you simply hold it with the same orientation and move the leads over.   My problem was that in my haste I dropped the old cap and lost my orientation.   So much so that when I attempted to start the engine, it was extremely unhappy and didn’t start at all.  Obviously I had the order wrong.

This shouldn’t be a problem though.   If you can identify #1, you can start there and go around the cap with the firing order of the engine.   This is 1,5,3,6,2,4.   It wasn’t obviously apparent which one was #1.   In the end I discovered two ways of doing it.

The first is on the distributor there is a very fine line marked on the top of the outer rim where #1 should be.    You should be able to feel it with your fingernail.   From there, I noticed that the cap is actually marked.   There is a subtle raised section next to where the lead goes into #1.    In the photo below I have marked it with white paint.

M129 rough running

The first time I did this, I just pulled on each lead to try and trace to each cylinder.   This is the lazy way to do it, as in the end I was wrong and the car still didn’t run.   Instead, I ended up doing it properly by taking off the leads and numbering each one, and also numbering the cap.    Perhaps overkill, but I ended up with a running engine this way.

The next step was to replace the plugs.   I had found these all fouled up on the 450SLC after I replaced those injectors.   They were even worse on the 250SE.    At least these plugs are much easier to swap out.  There are only six and access is very easy.

M129 rough running

After replacing the plugs I took the car for a test drive.  It is a lot better.   Still not perfect but now all these components are fixed, it is probably worth having it tuned again.   It may also benefit from some good drives to clear everything out.    I’m planning on taking the car on a longer drive next week and will probably also take it on the next night drive.    At least for now, I seem to have no more M129 rough running.

Fuel leak damage repaired

I recently changed the fuel pump and rear fuel hoses on my Jaguar E-Type.   In doing this change I learned a few things.   Firstly, the old pump had not been delivering enough fuel, as the car was significantly more responsive.   Secondly, fuel had obviously been leaking for a while as the paint had been eaten away in the spare tyre well.

For both these reasons I wanted to take the car in to be checked my by mechanic.   Now the engine was getting enough fuel I wanted to make sure the tune was right.  I also wanted to repair the fuel leak damage.  This meant fixing up the areas where the paint was damaged so rust did not start.

fuel leak damage

This was done in the spare wheel well so once I got the car home I could replace the spare tyre, tools, jack, and the trim in the boot.  The spare tyre was completely flat so a good opportunity to pump it up again.   While they were at it they replaced the plugs and gave the engine a quick tune.   It drives really well – much better than before.

Earlier this week there was an informal drive with the Mercedes club.   While the E-Type is obviously not a Mercedes, it was too good and opportunity to get the car out for an extended drive before the weather gets too hot.   We had a great drive down to Goulburn on the freeway, then up to Oberon via the back roads and back via Bells Line of Road.    The E-Type is really in its element on the twisty roads between Goulburn and Oberon,   The diff ratio change I did a couple of years ago also makes the car much better to drive.   It cruises happily at 120km/h on the freeway in 4th gear @2900RPM.  It also makes 3rd a much better passing gear as you can get up to decent speeds when overtaking before getting too close to the 5,000RPM redline.

At Bilpin fruit bowlOn the drive we had a Mercedes E400 Cabriolet, a BMW 545i and of course my E-Type.   One of the other drivers reported a bit of smoke when I lifted off the throttle of my E-Type.   I guess a little bit of oil is getting past a valve guide or valve seal.   Its not too bad at the moment but something to keep an eye out for in the future.    Overall I was really happy with how the E-Type drove.  With the fuel leak damage now being fixed I don’t have to worry about rust in this area either.

This is the second time I have taken the E-Type to Oberon.   Last time was the start of brake problems that would hamper the car for a while.   Luckily I did not have the same problems this time.

MBCNSW Dam Drive

Today I went on a drive with the MBCNSW to visit some historic dams to the South of Sydney.  The idea was to supposed to be to go to each dam and check it out and then have a picnic lunch at one of them.   Unfortunately the Sydney weather did not play ball and it was a rather wet and wild day.   I brought a couple of my kids to the dam drive as they liked the idea of a picnic at the dams.

MBCNSW Dam Drive

The meeting point was at a carpark in the Sutherland Shire.   The weather had been quite rainy the day before, but it looked like it might be clearing.   I took my 560SEL on the Dam drive.   I had originally planned to bring the 450SLC, but I haven’t changed the fuel pressure accumulator yet.   Stopping at each dam might have been a bit of a pain with the hard hot starting.   In the end it was a good choice as the W126 is a better wet weather car.

As the weather was a bit iffy, attendance was weighted towards the modern cars.   There were three W126s and an R107 450SL.    Showing the popularity of the AMG cars in the club, a number of the modern models were AMG versions.

The first stop on our Dam drive was to be Woronora dam.    As we got there, the weather started to take a turn for the worse, but at least we were able to have a bit of a look.   I didn’t take many photos due to the weather.

from there, we proceeded to Cordeaux Dam.    We made it to the Dam, but the rain started bucketing down after that.   Instead of proceeding to Avon dam (supposed to be the next one on the Dam drive), we abandoned the drive from there.   Its a shame the weather turned out that way, as I think it would have been a really good drive.

A very wet 450SL on the dam drive

Most of the group went to a local pub for lunch.    My kids were keen on the picnic, as were the kids of another couple of friends on the drive, so we found some undercover tables and had the picnic.   We were visted by some very tame parrots who must be used to begging for food from picnickers.

My car with a parrot on the Dam drive

Even given the rain, it was still a nice drive and good to get the 560SEL out to stretch its legs.     I would like to try this drive again when the weather is good.